DNS323, windows 7 explorer and Twonky media server 6.0

D-Link specific stuff goes here
elsiebuck
Posts: 12
Joined: Thu Jan 05, 2012 3:13 am
AV Hardware: D-Link 323
Sony Media Player 100

DNS323, windows 7 explorer and Twonky media server 6.0

Postby elsiebuck » Sat Jan 07, 2012 8:13 pm

Before I installed Twonky, windows exporer could access the nas. After installing Twonky, explorer could not access the nas. I could ftp. My media player did great. I even did a factory reset on the nas and after a few minutes the explorer again could not access the nas. I finially chmod 666 starttwonky.sh and rebooted. Explorer now works, but of course Twonky isn't.

Anyone know what I need to do to get BOTH working at the same time?

elsiebuck
Posts: 12
Joined: Thu Jan 05, 2012 3:13 am
AV Hardware: D-Link 323
Sony Media Player 100

Re: DNS323, windows 7 explorer and Twonky media server 6.0

Postby elsiebuck » Mon Jan 09, 2012 10:11 pm

What??? No one have any answers??? This is obviously a Twonky problem, not nas.

User avatar
parnott
Posts: 326
Joined: Mon Sep 20, 2010 9:55 pm
AV Hardware: Twonky, WDTV Live, XBMC (Linux & Windows)

Re: DNS323, windows 7 explorer and Twonky media server 6.0

Postby parnott » Tue Jan 10, 2012 12:06 am

What instructions did you use to install Twonky?

It sounds like you have not relocated the Twonky appdata directory and the partition containing the /var directory is being filled to capacity.

Search the forum for how to relocate the appdata directory. It has been discussed several times.

elsiebuck
Posts: 12
Joined: Thu Jan 05, 2012 3:13 am
AV Hardware: D-Link 323
Sony Media Player 100

Re: DNS323, windows 7 explorer and Twonky media server 6.0

Postby elsiebuck » Tue Jan 10, 2012 5:56 am

parnott wrote:What instructions did you use to install Twonky?

It sounds like you have not relocated the Twonky appdata directory and the partition containing the /var directory is being filled to capacity.

Search the forum for how to relocate the appdata directory. It has been discussed several times.


The instructions I followed are here:
http://forums.linn.co.uk/bb/showthread.php?tid=10532

Do you think the appdata shouldn't be in mnt/HD_a2/ ???

elsiebuck
Posts: 12
Joined: Thu Jan 05, 2012 3:13 am
AV Hardware: D-Link 323
Sony Media Player 100

Re: DNS323, windows 7 explorer and Twonky media server 6.0

Postby elsiebuck » Tue Jan 10, 2012 4:08 pm

Do I have a clue?

I didn't realize - but THAT (appdata) was my problem - THANK YOU !

All is well again in my world ! :lol:

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: DNS323, windows 7 explorer and Twonky media server 6.0

Postby Briain » Tue Jan 10, 2012 4:11 pm

Hi

I compiled the instructions you've likely followed. The link in your above post points to the tree changing in a Qnap, so I guess you followed the ones here. I've used them to install 6.0.34 in a couple DNS323's (for friends) and a few others have also successfully followed them. One person had all sorts problems and it took us ages to get to the bottom of it. It turned out that he was installing it using a Windows 7 PC and for some odd reason, it wasn't installing all the files via the Twonky telnet installation script (and Twonky simply wasn't starting). Most odd, and I can only assume it was some security feature in W7 that was causing the problem, but when he tried it on a borrowed XP laptop, it sailed on and Twonky started as expected.

The only critical bit about the installation is to untick the start Twonky checkbox that appears in the installation utility. If you forget to untick that, it will start Twonky and fill up the root. By unticking it, it prevents Twonky starting, and after the NAS reboots, it picks up the symlinks and then starts Twonky with everything going where it should be. Could it just be that tickbox issue?

Bri

EDITIt looks like we were both typing at exactly the same time!

Bri :D


Return to “D-Link DSM...”

Who is online

Users browsing this forum: No registered users and 2 guests