Problem with video streaming on the 360 after spring update

General discussion about the media server. Feature requests. Hints, tips and tricks.
monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Problem with video streaming on the 360 after spring update

Postby monkeyhands » Wed May 09, 2007 11:50 pm

Hi all,

Since the 360 spring dashboard update it says there are no videos to view on my twonky-hacked linkstation where there were before. I read this :-

http://blogs.msdn.com/xboxteam/archive/ ... k-faq.aspx

In particular point 18:-

18. After the May 2007 update, my 3rd party software doesn't stream videos correctly. Why?

Video navigation was changed in the May 2007 update. 3rd party software that does not support folders through network sharing will not work correctly. You'll have to contact the software developer for support.

So, any news on a fix guys?
Reality (n), Something that happens when you are not playing video games.

Taomyn
Posts: 24
Joined: Mon May 07, 2007 12:13 pm

Postby Taomyn » Thu May 10, 2007 1:16 pm

I got the following back from an email to the support guys here:

Hi,

we are working on an update which we hope can be released next week.

Thanks
The TwonkyVision Team


I hope it can be sooner - it seems like it's a simple fix as the TVersity chaps got a patch out a few hours after it was reported. Just a hint guys :wink:

daviec
Posts: 15
Joined: Thu Feb 08, 2007 2:02 pm
Contact:

Postby daviec » Thu May 10, 2007 6:04 pm

I'm having the same problem :(

I see it'll require support for folders through the network share. That could come in handy as I keep individual episodes of full TV series on my media server and it would be good to have them in folders instead of having to scroll down past 30+ episodes of the same show.

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Thu May 10, 2007 6:30 pm

Thanks for the replies. I look forward to the update :)
Reality (n), Something that happens when you are not playing video games.

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Postby mgillespie » Thu May 10, 2007 11:00 pm

Wouldn't it be simpler for people to get Microsoft to conform to DLNA standards for streaming, and then this mess won't occur....
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Fri May 11, 2007 1:33 am

From what I read, they seem to be moving away from UPnP ... M$ indicated that Windows Media Connect which is there (poor) attempt to implement it *was not supported anymore by the 360 even if it still *works*. My bet is that the cut it off in a couple of years for something proprietary.
Patrick S.
Roku HD1000 (Revived!), R1000, M1001 x2
Axiom M50Ti, QS4, CTC-20
D-BOX David 301
Yamaha RXV596, CDC-675, KXW492
JVC XVS40, HRVP56U, AV27D302
Logitech Harmony 880
Linksys NSLU2 x2 (320gig & 250gig W.D.)
Netgear WGR614,GS608,GS605 x3

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Mon May 14, 2007 6:34 pm

Bump!
Reality (n), Something that happens when you are not playing video games.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Mon May 14, 2007 6:56 pm

Hi,

we are about to release 4.3 - mainly because of the XBOX360 video problems.

We also change to a CD Key license by this version - for testing now you should
just be ok with the 30 day trial - we will send the keys together with the real
release.

The version 4.3 is here:
http://www.twonkyvision.com/Download/Tw ... x-4-3.html

What's new in Version 4.3
-------------------------

new Features:
+ XBOX 360 features: folder browse on videos, mpeg4 and aac support, resume on videos
+ revised CD Key handling and trial version
+ supportr for Nokia N95 with upload

Changes:
o changed default sort to: +upnp:artist,+upnp:album,+upnp:originalTrackNumber,+dc:date,+dc:title
o added mime type conversion to client DB file
o added time stamp to windows log file
o enhanced debug output on file scanning and playlist reading
o fixed enableweb=3, needs DYNDNS setting as well
o TwonkyMusic is discontinued from 4.3 on

Bug fixes:
- fixed library update message on MCW770
- search now delivers all titles with same name if these are from separate artists

Taomyn
Posts: 24
Joined: Mon May 07, 2007 12:13 pm

Postby Taomyn » Mon May 14, 2007 7:38 pm

Thank-you.

However, two problems encountered upgrading to Terastation version:

1> Would not upgrade - no errors, just kept to 4.2.1 even after reboot of NAS. Had to uninstall/install, but no biggy to me as still evaluating.

2> Xbox 360 now sees folders, but not all of them and then never more than 24 in any one folder, including All Videos (The media browser in Firefox show them all, so I know Twonky has scanned them).

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Mon May 14, 2007 11:44 pm

Nice one.

All working fine and dandy here.

Thanks!
Reality (n), Something that happens when you are not playing video games.

MiloDC
Posts: 15
Joined: Tue Jan 09, 2007 8:52 am
Location: San Diego, USA

Postby MiloDC » Tue May 15, 2007 1:33 am

twonky-christian wrote:The version 4.3 is here:
http://www.twonkyvision.com/Download/Tw ... x-4-3.html


Any word on when the 4.3 Infrant ReadyNAS plug-in will be released?

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Tue May 15, 2007 9:58 am

Infrant will be done when 4.3 is stable

Thanks for the report on the folder/24 video problem....

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Tue May 15, 2007 10:23 am

just tested with 29 videos and it worked fine :(

Taomyn
Posts: 24
Joined: Mon May 07, 2007 12:13 pm

Postby Taomyn » Tue May 15, 2007 11:03 am

twonky-christian wrote:just tested with 29 videos and it worked fine :(


Are they in sub-folders off the folder that the server is set to scan in?

E.g. The server scans \TV but the files are in \TV\BSG \TV\Heroes \TV\Scrubs etc and I also scan \Movies but all the movies are in that single folder

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Tue May 15, 2007 1:39 pm

subfolder

video\wmv

Taomyn
Posts: 24
Joined: Mon May 07, 2007 12:13 pm

Postby Taomyn » Tue May 15, 2007 1:50 pm

twonky-christian wrote:subfolder

video\wmv


Hmmm.....I'll take pictures tonight of what my 360 and ShowCenter display so you get an idea. I just think it's a coincidence it stops at 24 seeing as that is what the MediaBrowser via Firefox shows me (I'll screen shot those too).

UPDATE: I mean tonight :wink:
Last edited by Taomyn on Wed May 16, 2007 1:46 pm, edited 1 time in total.

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Wed May 16, 2007 1:37 pm

I've found another wierd problem with the music server.

When i go to music/computer/twonkymediaserver/album on the xbox360 dashboard, it lists all the albums but won't let me go into the album to choose a track. If I press "Y" to "play album" i get a "building playlist" message and then the songs will play no problem.

This did not occur with the previous version of twonky, pre or post 360 spring update.

Not a show-stopper but still fairly annoying.
Reality (n), Something that happens when you are not playing video games.

Taomyn
Posts: 24
Joined: Mon May 07, 2007 12:13 pm

Postby Taomyn » Wed May 16, 2007 4:43 pm

twonky-christian wrote:subfolder

video\wmv


I have an archive with screen shots from Firefox and images of my 360 to illustrate the problem. It's approx 5mb. Can I email them to you or can I upload them somewhere?

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Wed May 16, 2007 9:15 pm


turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Postby turls » Thu May 17, 2007 1:38 pm

twonky-christian wrote:Infrant will be done when 4.3 is stable

Thanks for the report on the folder/24 video problem....


Well, I got an e-mail so 4.3 is officially released, and no version of Infrant Twonky so far has been ready to go when the official release first comes out--why can't you work closer with Infrant to get these released concurrently?

MiloDC
Posts: 15
Joined: Tue Jan 09, 2007 8:52 am
Location: San Diego, USA

Infrant's fault?

Postby MiloDC » Thu May 17, 2007 5:53 pm

turls wrote:
twonky-christian wrote:Infrant will be done when 4.3 is stable

Well, I got an e-mail so 4.3 is officially released, and no version of Infrant Twonky so far has been ready to go when the official release first comes out--why can't you work closer with Infrant to get these released concurrently?


Wow, yeah, it says on the home page now that the latest version is 4.3.

I once asked someone here why the Infrant add-on always lags far behind the other versions, and the answer I got was that it's all Infrant's fault. Not sure what we can do besides go to their forums and bug them about this -- which you are already doing.

Infrant was recently acquired by Netgear, I wonder if that has had anything to do with the delays...

daviec
Posts: 15
Joined: Thu Feb 08, 2007 2:02 pm
Contact:

Postby daviec » Thu May 17, 2007 6:29 pm

Since I upgraded to 4.3 on the NSLU2 my twonky server has disappeared. I can connect to the configuration page via internet explorer but my 360 can't find it, and neither does Cidero running on my laptop. :?

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Thu May 17, 2007 7:14 pm

It is not Infrants fault!

It is just that it takes a few days to build the release - and that they just need this time.

Nothing bad about this - we just wait until we send them the final release until we know its stable - so that they do not need to build the Addon over and over again.

It is always a problem between geting somethign stable - or getting something at first :?

turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Postby turls » Thu May 17, 2007 10:43 pm

Ok, I'm just going off of memory here but it has been a lot more than just a few days between when you release and when Infrant is ready in the past. And last time with 4.2 there was a glitch that you had to go back and switch and they said you made a change between what you sent them and what the final release actually ended up being anyway.

I understand where you are coming from but in this case a week or less should be reasonable to expect, right?

turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Re: Infrant's fault?

Postby turls » Thu May 17, 2007 10:45 pm

MiloDC wrote:Infrant was recently acquired by Netgear, I wonder if that has had anything to do with the delays...


This doesn't have anything to do with previous delays, as this just happened.

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Thu May 17, 2007 11:14 pm

I've noticed a similar problem with artist/album (that I described above on my 360) with my Roku Soundbridge.

The artist/album node will find an artist but rather than listing the albums, the Soundbridge list artist then just a massive list of all the tracks.

Do I need to submit this as a fault or does posting here count?
Reality (n), Something that happens when you are not playing video games.

MiloDC
Posts: 15
Joined: Tue Jan 09, 2007 8:52 am
Location: San Diego, USA

Days or weeks to bug test?

Postby MiloDC » Fri May 18, 2007 6:05 am

turls wrote:
twonky-christian wrote:It is not Infrants fault!

It is just that it takes a few days to build the release - and that they just need this time.

Nothing bad about this - we just wait until we send them the final release until we know its stable - so that they do not need to build the Addon over and over again.

It is always a problem between geting somethign stable - or getting something at first :?

Ok, I'm just going off of memory here but it has been a lot more than just a few days between when you release and when Infrant is ready in the past. And last time with 4.2 there was a glitch that you had to go back and switch and they said you made a change between what you sent them and what the final release actually ended up being anyway.

I understand where you are coming from but in this case a week or less should be reasonable to expect, right?


I can second that. In the case of 4.2, the lag time was definitely way more than "just a few days." Weeks was more like it.

Going by what Christian is saying, it sounds like the delay is due to QA. What I'm not sure about is why it is taking extra days or weeks to QA the ReadyNAS build.

What is so special about the ReadyNAS that more days or weeks are required for quality assurance? I just want a good reason. Put my mind at ease.

IanSav says that the delays might be due to an impending update to RAIDiator (this time around, anyway). Can anyone corroborate this?

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Fri May 18, 2007 5:55 pm

I got an email from support saying that an updated version of Twonky 4.3 has been posted.

I grabbed it and ran it and all my album/artist woes have been sorted.

Great support and a great update - cheers!
Reality (n), Something that happens when you are not playing video games.

User avatar
twonky-christian
Lynx Technology Staff
Posts: 1121
Joined: Fri Sep 10, 2004 3:16 pm
AV Hardware: PC
Location: Berlin
Contact:

Postby twonky-christian » Fri May 18, 2007 8:01 pm

Infrant Addon is online!!

These guys just needed a few hours! :D

turls
Posts: 16
Joined: Tue Sep 12, 2006 8:00 pm

Postby turls » Fri May 18, 2007 9:34 pm

Like I said on Infrant's board, they raised the bar pretty high for themselves this time. . .I'm rebooting my ReadyNAS with the new image now.

daviec
Posts: 15
Joined: Thu Feb 08, 2007 2:02 pm
Contact:

Postby daviec » Sat May 19, 2007 10:00 am

monkeyhands wrote:I've found another wierd problem with the music server.

When i go to music/computer/twonkymediaserver/album on the xbox360 dashboard, it lists all the albums but won't let me go into the album to choose a track. If I press "Y" to "play album" i get a "building playlist" message and then the songs will play no problem.

This did not occur with the previous version of twonky, pre or post 360 spring update.

Not a show-stopper but still fairly annoying.


This happening on mine and it is a showstopper for me. The playlist it generates is not in the track order. Most of my albums are CD mixes so they need to be played in order. Is there no way to enable the previous behaviour where you could go into each album folder and play from there?

monkeyhands
Posts: 26
Joined: Sat Sep 02, 2006 4:13 pm

Postby monkeyhands » Sat May 19, 2007 11:25 am

Hi Daviec,

Despite my post above, I'm still having a few issues with this.

If I set the music tree as basic default in Twonky, my 360 works fine, it lists all the albums OK (and now lets me pick a track) and in "artist" on the 360 dash it lists all the albums by that artist. But...

If I have twonky set up as above, my roku soundbridge gets the problem I described earlier, in artist/album it just lists all the songs in no order. But...

If I have twonky set as advanced default navigation, my soundbridge works fine, artist/album working as it should but my 360 gets confused by any albums that have more than one artist on eg "Work" by Orbital is listed as an album on my 360 a number of times as one track is by Orbital feat. Alison Goldfrapp, the next featuring david gray etc.

So, at the minute, i can get either my 360 OR my Soundbridge working right, but not both at the same time.

Daviec, did you get the new new version of 4.3 posted 18th may 07? If so have a play with the music tree - you should at least be able to get your 360 to work if that's the only player you use.
Reality (n), Something that happens when you are not playing video games.

zenkinz
Posts: 47
Joined: Tue Oct 17, 2006 1:16 pm

Postby zenkinz » Mon Jun 11, 2007 6:44 am

so has anybody tried successfully with video and music streaming using xbox 360 as the upnp client?

if so, which version of xbox 360 box/firmware should I be looking for? I am shopping for a xbox 360 or a ps3, and one of the critieria is to use it as a upnp client.


Return to “TwonkyServer”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests