Xbox360, Ubuntu, Xbox see's but won't play?

General discussion about the media server. Feature requests. Hints, tips and tricks.
doublehard
Posts: 2
Joined: Wed Jun 13, 2007 3:29 pm

Xbox360, Ubuntu, Xbox see's but won't play?

Postby doublehard » Wed Jun 13, 2007 3:41 pm

Hi

I've been playing around with Twonky and have managed to get my 360 to connect and see my music (although not all my music only 12 albums) anyway when I select an album (some are in WMA some in mp3) on the 360 screen there is a 'no-entry' sign on every track and it won't play them. If I go into pictures it puts a cross up where every image should be. I've tried this with Firestarter on and off but if makes no difference.

Any ideas?

info:
Xbox 360 up to date with downloads.
Twonky version 4.3 (on 30 day trial)
Ubuntu Fiesty Fawn

doublehard
Posts: 2
Joined: Wed Jun 13, 2007 3:29 pm

Postby doublehard » Wed Jun 13, 2007 4:01 pm

I might have more problems than I thought;

I've just opened the TwonkyVision Configurator and gone through the options, everytime I make a change (e.g. in the sharing option) and then save and restart the server it defauts back to blank. Media is being found but when I try to play them through the media browser it won't work. No music will play and no pictures can be seen, it does list them but with a broken link icon next to them.

Any ideas?

ally
Posts: 5
Joined: Fri Dec 29, 2006 12:38 am

Postby ally » Wed Jun 13, 2007 5:16 pm

I had problems when looking at in on Ubuntu, try using IE on a PC to change the configuration page. Firefox wouldnt submit the changes for me.

FlintZA
Posts: 7
Joined: Mon Jun 11, 2007 9:07 am

Postby FlintZA » Fri Jun 15, 2007 10:28 am

I recently set up Twonky with exactly the same setup and had the problems you're mentioning. When you installed Twonky, did you do it as superuser (using sudo)? Also, when you copied your media onto your linux system, did you perhaps do it with sudo?
I did that, and when I first ran Twonky everything was fine (because I ran it with sudo as well) but when I added it to session autostarts and rebooted the machine I got the no entry signs you mention.

Solution:
1. Use chmod and chown recursively on the top level folder(s) of your media library and of your Twonky installation directory to make sure that the user under which Twonky runs has ownership and full rights on all files.
2. Delete the Twonky DB (rebuild doesn't work, even after the chmod/chown) and use the admin page to rebuild the DB.
3. Enjoy :)


Return to “TwonkyServer”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron