Random memory usage

General discussion about the media server. Feature requests. Hints, tips and tricks.
flynn
Posts: 37
Joined: Tue Jun 12, 2007 8:28 pm

Random memory usage

Postby flynn » Wed Jun 13, 2007 9:08 pm

I've seen different values for the "Used memory", as reported near the top of the server stats config page, for the same collection of files.

I've been moving between the recent betas, and this usage has been changing drastically - sometimes the usage tops out at ~9MB, and with the 4.4B4 release it's at ~34MB. The pain here is that I have to change the max usage to react to this.

Here's what my content counts look like - I'm running on a D-Link DNS-323 NAS:

Content
Music tracks: 38957
Pictures: 11277
Videos: 388
Radio stations: 0

What memory usage should I expect?

User avatar
mgillespie
Posts: 1222
Joined: Fri Jul 08, 2005 1:19 pm
AV Hardware: TwonkyMedia AV UPnP Mediaserver (Marvell Kirkwood ARM Sheevaplug with Debian Squeeze).
2x Noxon V2 audio client
1x PS3 Slim 500GB Audio/Video UPnP client.
1x Sony VGF-CP1 Wireless Photoframe.
Location: UK

Postby mgillespie » Thu Jun 14, 2007 3:52 am

Perheps the mem usage is because it's scanning and indexing. Have you checked mem usage after it's settled down for say 5 hours? (40, 000 tracks is quite big)
Please note: Moderators here are voluntary and do not work for PacketVideo or Twonky, please do not attack us. Any posts are personal opinion, and may not be those of PV/Twonky.

flynn
Posts: 37
Joined: Tue Jun 12, 2007 8:28 pm

Postby flynn » Thu Jun 14, 2007 4:28 am

Yes, the numbers I'm quotting after after things have settled - I don't think I waited 5 hours for this, but I waited at least an hour and watched for memory activity to stop.


Return to “TwonkyServer”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests