Enableweb streaming how-to

General discussion about the media server. Feature requests. Hints, tips and tricks.
dogbot123
Posts: 2
Joined: Tue Jul 17, 2007 4:27 pm
Location: UK

Enableweb streaming how-to

Postby dogbot123 » Tue Jul 17, 2007 4:39 pm

Configuring TwonkyMedia 4.4 for remote internet access

This document attempts to document the steps necessary to configure TwonkyMedia 4.4 for remote access via the internet. It has only been tested under Microsoft Vista Ultimate and using a D-link DI-624 router

The steps listed are those that worked for me, there may well be things I’ve got wrong or could have achieved more efficiently, if so please let me know

Assumptions

For the purposes of this document the following has been assumed

1. Local host as a IP address of 192.168.0.99*
2. Local host is connected to a router with firewall functionality
3. ISP allocates IP addresses dynamically
4. Local.dyndsn.org* has been configured to resolve to the IP address currently allocated by the ISP (you must register at http://www.dyndsn.com)
5. Remote access to TwonkyMedia will be on port 9100*
6. All s/w has been installed in the default locations

* Substitute these with the information appropriate to your system


Configuration steps

Port forwarding on the Router (only very high level guide information provided, consult your routers manual for more detailed information)

7. Access you routers configuration page
8. Navigate to the port forwarding or virtual server section
9. Enter the IP address of the host you which to forward traffic to in this case 192.168.0.99 (Substitute with you own IP address)
10. Enter the protocol the be used as TCP
11. Enter the private port which traffic is to be sent to, in this case 9100 (Substitute with you own port number)
12. Enter the public port which the router is to listen for in this case 9100 (Substitute with you own port number, needs to be the same as the private port for twonkyMedia to provide correct URL when navigating)
13. Save the configuration and re-start your router if necessary


Enabling Twonkymedia security

14. Launch your web browser and navigate to http://192.168.0.99:9000/setup.htm (Substitute with you own IP address)
15. On the left of the screen under basic steps click on client/security
16. In the user name filed enter a user name of your own choice
17. In the password field enter a password of you own choice
18. On the left of the screen under Advanced steps click network
19. Ensure Web Access is set to Local access to web configuration pages (this prevents remote access to the configuration pages via http://local.dyndsn.org:9100/setup.htm )
20. Click on Save Changes

Editing the Twonkyvision-mediaserver.ini file

21. Using windows explorer navigate to c:\windows\system32\config\systemprofile\roaming\twonkymedia
22. Right click on Twonkyvision-mediaserver.ini and select edit from the sub-menu
23. Locate dyndns= and change it to dyndns=http:// local.dyndns.org:9100 (Substitute with your own dynamic address and port number)
24. Locate enableweb= and ensure it is set to enableweb=1 (should already be set to 1 following step 19)
25. Locate httpremoteport= and change it to httpremoteport=9100 (Substitute with your own port number, same as step 22)
26. Save the ini file, overwriting the original
27. Re-boot your PC.
Notes:
1. Make sure you edit the ini file described and don’t get confused with Twonkymedia-default.ini that can be found in c:\Program Files\Twonkymedia

2. Simply restarting the twonkymedia server from the configuration page will re-set the Twonkyvision-mediaserver.ini and the changes made in steps 23-25 will be lost

3. Do not use TCP port 9000 for remote access as this is already in use by twonkymedia for local access

You should now be able to assess you media server for the internet via http://local.dyndsn.org:9100/webbrowse


http://local.dyndns.org:9100/webbrowser also works but does not display the site graphics correctly

billkill
Posts: 4
Joined: Mon Aug 06, 2007 9:17 pm

How do I change the INI file on a NAS

Postby billkill » Thu Aug 09, 2007 9:54 am

How do I change the INI file on a NAS

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Thu Aug 16, 2007 4:14 pm

I have been toying with this without much success ...
Here is the setup:
NLSU2 Unslung behind a basic router to the internet

So I followed the steps but:

19. Ensure Web Access is set to Local access to web configuration pages (this prevents remote access to the configuration pages via http://local.dyndsn.org:9100/setup.htm )
Cannnot do this since Twonky resides on a NAS

21. Using windows explorer navigate to c:\windows\system32\config\systemprofile\roaming\twonkymedia
22. Right click on Twonkyvision-mediaserver.ini and select edit from the sub-menu
For those using a NAS, on my NSLU2, the file resides at the root under /twonkyvision

24. Locate enableweb= and ensure it is set to enableweb=1 (should already be set to 1 following step 19)
Please see comment of step 19, the value is 2

Also for editing, I used iconv to convert from and to utf-16 and edited the file via vi in utf-8. Tried with vim without much success. I would rather use vim on the slug, so if someone knows the magic command, please say so.

Now, I do a basic killall of the process and restart it via the /opt/etc/init.d/S99twonkyvision script

When it restarts, I loose some config :(
And once it restarts, should the process be also listening on the remote port also (on top of the 9000) ?
I wonder why all this setup is not available directly from the web page, it would be a lot easier than messing with a utf-16 (BTW, why utf-16 ?!?).
So if someone could fill me in on the missing pieces to get it up and running ?
Thanks in advance
Patrick S.
Last edited by sansp00 on Thu Aug 16, 2007 4:30 pm, edited 1 time in total.
Roku HD1000 (Revived!), R1000, M1001 x2
Axiom M50Ti, QS4, CTC-20
D-BOX David 301
Yamaha RXV596, CDC-675, KXW492
JVC XVS40, HRVP56U, AV27D302
Logitech Harmony 880
Linksys NSLU2 x2 (320gig & 250gig W.D.)
Netgear WGR614,GS608,GS605 x3

wideasleep1
Posts: 338
Joined: Mon Jul 11, 2005 4:34 am
Location: Sausalito,Ca. USA
Contact:

Postby wideasleep1 » Thu Aug 16, 2007 4:22 pm

Kos and others are right...one needn't be a linux-whiz just to get this feature running on a NAS. I envision a question-and-answer session in the installer: 'Would you like to enable web-access during this install?" (you must open port 9001(etc.) on your router for web-access).

Surely it wouldn't be difficult to to all the work behind the scenes, rather than have everyone learn utf-16, chmod mumbo-jumbo?

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Thu Aug 16, 2007 4:34 pm

Worst thing is that I am far from being a unix noob ... But documentation is very thin on this aspect. Im not complaining, but it's not the most intuitive setup to do.
I would rather be able to do it via the config page and also have to possibility to restrict the IP's that access it instead of the local/non-local option. I don't think I am asking for much here ...
Patrick S.
Roku HD1000 (Revived!), R1000, M1001 x2

Axiom M50Ti, QS4, CTC-20

D-BOX David 301

Yamaha RXV596, CDC-675, KXW492

JVC XVS40, HRVP56U, AV27D302

Logitech Harmony 880

Linksys NSLU2 x2 (320gig & 250gig W.D.)

Netgear WGR614,GS608,GS605 x3

billkill
Posts: 4
Joined: Mon Aug 06, 2007 9:17 pm

Very nearly there

Postby billkill » Thu Aug 16, 2007 8:44 pm

OK I have spent a lot of time on this now trying to get thus feature to work on my linkstation and I am nearly there when accessing webbrowse from a remote location I get to the main page which shows my shares but when I click on any of them I just get taken to the main twonky setup page

If I click on a share the URL looks like this

http://mystaticip:9100/#%20dlnastrict/webbrowse/O1

anyone have any ideas

I have changed the twonky-mediaserver ini to the correct 9100 settings

do I need to alter anyother ini files?

The strange thing is that is I go to the remote url but port 9000 that works but all links are on an internal ip address

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Fri Aug 17, 2007 2:28 am

I am unable to make the changes to the ini file 'stick' ... Each time I restart the server, they get overridden with the previous version :(
Any insights on this ?
Patrick S.
Roku HD1000 (Revived!), R1000, M1001 x2

Axiom M50Ti, QS4, CTC-20

D-BOX David 301

Yamaha RXV596, CDC-675, KXW492

JVC XVS40, HRVP56U, AV27D302

Logitech Harmony 880

Linksys NSLU2 x2 (320gig & 250gig W.D.)

Netgear WGR614,GS608,GS605 x3

wideasleep1
Posts: 338
Joined: Mon Jul 11, 2005 4:34 am
Location: Sausalito,Ca. USA
Contact:

Postby wideasleep1 » Fri Aug 17, 2007 3:57 pm

sansp00 wrote:I am unable to make the changes to the ini file 'stick' ... Each time I restart the server, they get overridden with the previous version :(
Any insights on this ?
Patrick S.


Exactly my problem,too. I chmod'd the file to 777 (I think,I guess), and changed enableweb, but then vista says basically utf16 warning when saving file, and I haven't revisited it since. Tried three times and gave up. Odd thing is I'm certain I had this web-access working in prior versions before it was even announced as an add-on. :|

warti
Posts: 51
Joined: Sun Jul 10, 2005 7:40 pm

Postby warti » Fri Aug 17, 2007 6:47 pm

Hi Patrick, wideasleep1,

I have had the same problem on my NAS (NLSU2). After restart of TV (TwonkyVision) using the TV-web frontend all changes in the ini-file were lost :shock:

Then I killed TV manually (killall twonkymedia) I made the changes in the ini-file and start TV manually - and then it worked :o !

The reason?
Perhaps TV is storing - before shutting down - the ini-file with it's current settings. So the manual changes made in between get lost.

Idea: Stop TV before modifying the ini-file. (I did not test it - never touch a running system :wink: )

regards,
Werner

Kos
Posts: 205
Joined: Tue May 23, 2006 3:55 pm
Location: Frederiksberg, Denmark

Postby Kos » Sat Aug 18, 2007 8:52 am

Christian, Richard or other Twonky officials - it's about time you realise that even the biggest Twonky ambassadors (us!) are unable to implement (and defend!) your latest feature - remote access. Please act like you care for us - and respond.

Kos
Setup: D-link635/Linksys(wifi), PhilipsSLA5520/Noxon iRadio, Sonos ZP90+ZP120+S5+CR200, iPod Touch & iPad2, Twonky6.0.30(server), MaxtorSS+/Qnap TS-109+112 (NAS'es), MediaMonkey 4(media manager)

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Sat Aug 18, 2007 10:04 pm

Got really frustrated with trying to get the ini file ... Ran the the twonky executable with the -help for the heck of it and notice that all the parameters could be passed at the command line !

Got it to work with the following command line in the S99twonkyvision file under /opt/etc/init.d

/share/flash/data/twonkyvision/twonkymedia enableweb 1 -httpremoteport [MY PORT] -dyndns [MY DYNDNS:MY PORT] &

I hope this will help others ...
Patrick S.
~
Roku HD1000 (Revived!), R1000, M1001 x2

Axiom M50Ti, QS4, CTC-20

D-BOX David 301

Yamaha RXV596, CDC-675, KXW492

JVC XVS40, HRVP56U, AV27D302

Logitech Harmony 880

Linksys NSLU2 x2 (320gig & 250gig W.D.)

Netgear WGR614,GS608,GS605 x3

masterplumber
Posts: 31
Joined: Tue May 16, 2006 3:48 pm
Location: Bedford Falls, Stirlingshire, Scotland
Contact:

Postby masterplumber » Mon Aug 27, 2007 10:33 am

after a lot of time trying to get this to work I used sansp00's suggestion. Worked a treat!
there's danger in complacency and comfort in the fight

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Mon Aug 27, 2007 10:48 am

Glad to see someone else benefited from my wall head banging :lol:
Patrick S.
Roku HD1000 (Revived!), R1000, M1001 x2

Axiom M50Ti, QS4, CTC-20

D-BOX David 301

Yamaha RXV596, CDC-675, KXW492

JVC XVS40, HRVP56U, AV27D302

Logitech Harmony 880

Linksys NSLU2 x2 (320gig & 250gig W.D.)

Netgear WGR614,GS608,GS605 x3

ricvilla
Posts: 1
Joined: Tue Aug 28, 2007 4:47 am

Setting the INI file

Postby ricvilla » Tue Aug 28, 2007 4:59 am

Here is what I had to do in order for remote access to work...

Server: Maxtor Shared Storage, Client: XBox 360

1. Stop the twonkymedia process in the server.
2. Remove the twonkyvision-mediaserver.ini file (careful, you will have to recreate all your settings afterwards!)
3. Add the three parameters (enableweb, httpremoteport, dyndns) with their corresponding values to twonkymedia-default.ini file.
4. Start the twonkymedia process in the server.
5. Reconfigure the server for license key and shares.
6. Voila, remote access working like a charm.

For the Twonky Media developers: Right now I can only remotely play songs one by one... is this the intended functionality?

sansp00
Posts: 44
Joined: Tue Mar 27, 2007 3:12 pm
Location: Beloeil, Quebec
Contact:

Postby sansp00 » Tue Aug 28, 2007 2:58 pm

The procedure you just mentioned does not work on the NSLU2 platform. The file gets overwritten :(

On *nix platforms, the parameter passing when starting the twonkymedia daemon *should* be full proof. And it has the advantage of not messing with the .ini file which can be hazardous and complicated if you do not have a UTF-16 editor.

Patrick S.
Last edited by sansp00 on Thu Aug 30, 2007 3:05 pm, edited 2 times in total.
Roku HD1000 (Revived!), R1000, M1001 x2

Axiom M50Ti, QS4, CTC-20

D-BOX David 301

Yamaha RXV596, CDC-675, KXW492

JVC XVS40, HRVP56U, AV27D302

Logitech Harmony 880

Linksys NSLU2 x2 (320gig & 250gig W.D.)

Netgear WGR614,GS608,GS605 x3

masterplumber
Posts: 31
Joined: Tue May 16, 2006 3:48 pm
Location: Bedford Falls, Stirlingshire, Scotland
Contact:

Postby masterplumber » Thu Aug 30, 2007 2:52 pm

it has the advantage of not messing with the .ini file


Agreed. If you're using a slug, simply stick a couple of parameters into the S99twonkyvision file as specified above, reboot and away you go.
there's danger in complacency and comfort in the fight

kitenski
Posts: 5
Joined: Mon Sep 03, 2007 2:24 pm

Postby kitenski » Tue Sep 04, 2007 10:28 am

For Buffalo Terastation users, I had to slightly modify the instructions above.

So edit the twonky file at this location:

/etc/init.d

and edit it so the last line looks like this

/mnt/array1/share/twonky/twonkymedia -enableweb 2 -httpremoteport 9100 -dyndns http://yourwanipaddress:9100 &

Note with a NAS box you cannot have enableweb of 1!

Cheers,

greg
http://www.pocketpcsoft.net PocketPC forums, software and freeware

http://www.smartphonesoft.com for Smartphone software and freeware

kfurter
Posts: 9
Joined: Mon Jan 15, 2007 7:40 pm

Postby kfurter » Sat Dec 08, 2007 11:20 am

For Maxtor MSS Plus again slightly different but works great! Wonderful idea!

/shares/mss-hdd/__twonkymedia/twonkymedia -enableweb 2 -httpremoteport 9100 -dyndns http://yourwanipaddress:9100 &

Finally this works - but would be great if there would be as well a password as you enter the webbrowser!

kfurter
Posts: 9
Joined: Mon Jan 15, 2007 7:40 pm

Postby kfurter » Tue Dec 11, 2007 10:07 pm

Too quick :cry:

While I can now access the first page "Webbrowse" I can't access anything further - In Firefox I get an errormessage stating that it does not know how to handle it; in IE it just brings an error page.

Anybody an idea? How did you successfully got this working? What do I miss?

chucksel
Posts: 4
Joined: Wed Dec 12, 2007 1:04 am

How can you receive the STREAM in Vista?

Postby chucksel » Thu Jan 03, 2008 2:15 am

Hi. Followed the directions. I can get to the remote Twonky media server via the web and can browse folders. However, when I click the song, it tries to copy the file instead of STEAMING the music to my Vista laptop.

Any ideas of how I get the file to STREAM the music to me instead of getting a copy of the entire file?

Thanks in advance!

Chucksel

WiseYoda
Posts: 2
Joined: Thu Jan 24, 2008 10:48 pm

Postby WiseYoda » Thu Jan 24, 2008 10:55 pm

I'm running Twonky 4.4.3 on a LaCie Ethernet Big Disk NAS... and don't have access to any of the above (please please correct me if I am wrong). I know this isn't the best solution, but I wrote a quick Grease Monkey script in Firefox that swaps out the IP addresses.

Obviously this will only work for the computer you have it installed on, but if you access it from the same outside computer (aka your work computer) then this solution can be a nice band aid in the time being.

Code: Select all

// ==UserScript==
// @name           Change IP Address
// @namespace      twonky
// @description    Change Twonky IP Address
// @include        http://11.222.333.4:9000/*
// @exclude      http://11.222.333.4:9000/setup.htm
// ==/UserScript==

var links = document.getElementsByTagName("a");
for (var i = 0; i < links.length; i++) {
    link = links[i];
    link.href = link.href.replace('192.168.1.150', '11.222.333.4');
}

var imgs = document.getElementsByTagName("img");
for (var i = 0; i < imgs.length; i++) {
    img = imgs[i];
    img.src = img.src.replace('192.168.1.150', '11.222.333.4');
}


11.222.333.4 would be your public IP address
192.168.1.150 would be your internal IP address

I'm hoping that LaCie releases a new version of Twonky for this product, but in the meantime, enjoy.

raven
Posts: 43
Joined: Wed Apr 26, 2006 2:16 pm

Re: How can you receive the STREAM in Vista?

Postby raven » Sat Feb 02, 2008 5:25 pm

chucksel wrote:Hi. Followed the directions. I can get to the remote Twonky media server via the web and can browse folders. However, when I click the song, it tries to copy the file instead of STEAMING the music to my Vista laptop.

Any ideas of how I get the file to STREAM the music to me instead of getting a copy of the entire file?

Thanks in advance!

Chucksel


I would like to know this as well!

raven
Posts: 43
Joined: Wed Apr 26, 2006 2:16 pm

Postby raven » Thu Feb 07, 2008 8:50 am

A solution is to select an album and press the triangle in front of it, a playlist will be generated and this can be opened by a suitable program (winamp, mediamonkey, etc etc,) without downloading the songs.

Sysweb
Posts: 1
Joined: Wed May 07, 2008 5:51 pm
AV Hardware: Linkstation Live 250GB
PS3
Twonky
Window XP

Re: Enableweb streaming how-to

Postby Sysweb » Wed May 07, 2008 6:03 pm

kitenski wrote:For Buffalo Terastation users, I had to slightly modify the instructions above.

So edit the twonky file at this location:

/etc/init.d

and edit it so the last line looks like this

/mnt/array1/share/twonky/twonkymedia -enableweb 2 -httpremoteport 9100 -dyndns http://yourwanipaddress:9100 &

Note with a NAS box you cannot have enableweb of 1!

Cheers,

greg


Hi, I got it working via the normal web config pages....

I simply tick the following setting on the "network" config page


Restart on NIC changes: True (ticked)

HTTP remote port: 95* - you pick what you want

and here's the magic to stop twonky putting in the local ip address of the Linkstation....

Dynamic DNS : / - yes thats right just "/" - nothing else

Save and restart the twonky server.... and away you go...

Regards

John

Boogieman117
Posts: 4
Joined: Thu May 08, 2008 5:12 pm
AV Hardware: Twonky is running on a white-box P4 2.53GHz with 2GB of 400MHz RAM
Within my home network, I stream to my laptops/desktops/PS3(60gb)
Outside of my home network, I stream to my work computer. Hoping to stream to my cell phone one day.

Playing with the trial, loving it!

Re: Enableweb streaming how-to

Postby Boogieman117 » Thu May 08, 2008 5:21 pm

Could anyone elaborate on Step #4?

I've got everything configured for my home setup, but I'd like to stream my stuff outside the home network. Problem lies when I connect to http://externalip:9000, I hit my twonkyvision server like normal, click PC Browser, and I can see in the status bar when I hover over the Audio, Video, and Picture links that it links to the http://localipaddressathome:9000/..., which doesn't help much. :D

Thanks,
Joey aka Boogieman117

WinnetouKoslowski
Posts: 25
Joined: Tue Aug 01, 2006 10:50 pm

Re: Enableweb streaming how-to

Postby WinnetouKoslowski » Thu Jul 17, 2008 1:14 am

Ok. I got it fixed. It is working fine. I had another little problem: The Port was not taken from the ini file and i had to change it to 9101. Works great. Nice program.

//ok, changed harddisk, reinstalled twonky 4.4.9 and the webpages links always pointed to bogus locations as mentioned above. First page displayed fine but navigation was broken. What i changed to get it working again:

Code: Select all

# Dynamic DNS
dyndns=http://WinnetouKoslowski.dyndns.org:9101

# Netzzugang
enableweb=1

# HTTP remote port
httpremoteport=9101


But most of all i used TwonkyVision UPnP Media Server Version 4.4.3.1 again.
I am using an ASUS WL-HDD with Oleg Firmware.
Last edited by WinnetouKoslowski on Thu Oct 16, 2008 3:23 pm, edited 1 time in total.

tmking
Posts: 1
Joined: Tue Aug 26, 2008 9:12 pm
AV Hardware: WIndows XP, Roku Soundbridge

Re: Enableweb streaming how-to

Postby tmking » Tue Aug 26, 2008 9:22 pm

Sorry Twonky developers but it just doesnt work, no matter what I do the remote web page always provides links to the local host ip address, it seems that the media server does not attempt to change the links based on where the request is coming from whihc is what I think should be happening.
I'm assuming that what is supposed to happen is something like this:

Access the server from within local network the music link is something like : http://192.168.1.8:9100/webbrowse/O1
Access the server from outside the local network (remote web access) should be something like: http://myweb.dyndns.org:9100/webbrowse/O1

But this is not what happens, the remote link always shows the local ip address, I reckon the TwonkyMedia just doesn't handle remote access properly.

NELLY
Posts: 1
Joined: Mon Sep 08, 2008 5:56 pm
AV Hardware: XBOX 360 and an Archos 605 wifi

Re: Enableweb streaming how-to

Postby NELLY » Wed Sep 24, 2008 5:23 pm

I've tried the above and it has worked to a degree.
All I get is my router control panel.
I am able to log in to this and make changes but I do not get Twonky coming up.
A little help please.

Macsimpsons
Posts: 1
Joined: Fri Nov 07, 2008 11:01 pm
AV Hardware: Buffalo Linkstation Live

Re: Enableweb streaming how-to

Postby Macsimpsons » Wed Nov 12, 2008 7:36 pm

Hello
Try to find this file,
c:\windows\system32\config\systemprofile\roaming\twonkymedia

But there is only c:\windows\system32\config\systemprofile and no roaming or tronkymedia.

How can i find these file?

Thanks

ColoBoiler
Posts: 1
Joined: Thu Nov 13, 2008 10:14 am
AV Hardware: PCs with XP, NSLU2

Re: Enableweb streaming how-to

Postby ColoBoiler » Thu Nov 13, 2008 9:12 pm

Sysweb wrote:Hi, I got it working via the normal web config pages....

I simply tick the following setting on the "network" config page


Restart on NIC changes: True (ticked)

HTTP remote port: 95* - you pick what you want

and here's the magic to stop twonky putting in the local ip address of the Linkstation....

Dynamic DNS : / - yes thats right just "/" - nothing else

Save and restart the twonky server.... and away you go...

Regards

John


I got remote access working finally on my NSLU2 using this method last night. One problem that I ran into was that cookies were preventing the change to the Dynamic DNS field from something I had tried earlier to "/". I would make the change as described above, save, then restart the server, only to find that the field reverted back to its original value. After about 45 minutes of frustration, I finally deleted my cookies and temporary internet files, which fixed the problem, then it worked fine.

Also, for anyone who, like me, blindly follows the instructions at the top of this thread for an NSLU2, only to find that you've locked yourself out of web access, you can get web access back by running the twonkymediaserver from the linux command line and changing the enableweb value to 2, then opening the web tool and saving and restarting the server from there. Hopefully others can avoid my boneheaded mistakes.

sighlent
Posts: 1
Joined: Wed Jan 07, 2009 1:22 am
AV Hardware: PowerMac G5 running Twonk Media Server 5

Re: Enableweb streaming how-to

Postby sighlent » Wed Jan 07, 2009 1:24 am

I used to be running 4.4.9 on Mac OS X and this worked perfectly.

In version 5, this totally breaks and rewrites over my changes to the twonkymedia-server.ini file.

I think I want a refund.

mokihisa
Posts: 1
Joined: Thu Feb 05, 2009 7:59 am
AV Hardware: 1 - Windows XP Home - Intel P4 - 2GB RAM - 5 TB Drive Space
1 - Windows Vista - Sony Vaio Notebook
1 - Windows XP Home - HP Mini Netbook
1 - Windows XP Home - Sony Vaio Notebook
2 - Sony PS3 40 GB and 80 GB version.

Re: Enableweb streaming how-to

Postby mokihisa » Thu Feb 05, 2009 8:15 am

Like chucksel and raven before me, I'm able to access my TwonkyMedia Server remotly just fine.

Photos, music and video show up on my browser (IE7) and I can see all my media. But I also get a messages asking if I want to "open" or "save" to my computer when I click on a video.

Is there a setting on the TwonkyMedia Server side I need to set in order to have my video "stream" directly to my remote computer? TwonkyMedia Server works perfectly on my local network at home for my notebooks, and two PS3's. But I'd like to also access my videos from the internet remotely without having to download and save the video first.

Has anyone been able to "stream" video remotly to WMP11 or simlar client?

Thx! - Markos

BTW - This is not a compaint, I love TwonkyMedia Server and how it works at home. I'm just looking to access my videos when I'm away from my home.

walshchristopherj
Posts: 32
Joined: Wed Jul 25, 2007 2:33 pm

Re: Enableweb streaming how-to

Postby walshchristopherj » Mon Apr 20, 2009 2:54 am

This does not work in version 4.4.15. Please fix, thank you.

shaboyi
Posts: 2
Joined: Thu Aug 27, 2009 11:49 pm
AV Hardware: onkyo

Re: Enableweb streaming how-to - For ver 5?

Postby shaboyi » Fri Aug 28, 2009 5:04 am

Is it possible to allow remote web access for version 5 (mac or windows)? It appears that many of the 'network' options are no longer available on version 5. thanks.

purpleguy
Posts: 1
Joined: Thu Dec 24, 2009 3:23 pm
AV Hardware: HP Mediasmart EX495
D-Link 615 UPnP enabled
XBOX
PS3

Re: Enableweb streaming how-to

Postby purpleguy » Thu Dec 24, 2009 3:40 pm

Maybe someone here can assist with my issue.

Bought a HP mediasmart ex495 with twonkymedia server (I think version 5.0 or 5.1 not sure how to find) pre installed. HP has restricted access to twonky setup and config web interfaces.

I have port fowarding and UPnP enabled on my d-link 615 9000 and have this port set up under the HP mediasmart console section for twonky.

Issue is this. I can access from the web via my ISP wan address xxx.xxx.xxx.xxx:9000 and get the initial page. But when I click on any media links twonky is returning an internal LAN ip of 192.168.1.xxx.

So my question is
-What file can I edit on my WHS w/ HP mediasmart to add an absolute url to media file collection so I can use twonky from outside my home network.

You may ask. Hey why not just use the HP streaming software? And I may tell you it sucks.

Any help would be appreciated.

Thanks

malaki86
Posts: 28
Joined: Mon Nov 26, 2007 10:40 pm

Re: Enableweb streaming how-to

Postby malaki86 » Fri Jan 01, 2010 3:54 am

Using the Dynamic DNS name as '/' is what it took to fix mine.

Crashdot
Posts: 4
Joined: Wed Jan 27, 2010 5:32 am
AV Hardware: Twonky Media Server 4.4.5 on Windows
Denon AVR-4306
Nokia N900

Re: Enableweb streaming how-to

Postby Crashdot » Wed Jan 27, 2010 5:41 am

I think I have my system configured correctly, but would appreciate any suggestions in getting around this problem.

I am attempting to enable remote access so I can run playlists and music from my home system on my Nokia N900 smartphone. It has a mozilla based web browser, and a UPnP capable media player that works properly with Twonky Media Server 4.4.5 locally for playlists, mp3s and video files.

When attempting remote/WAN access, I run into a problem. If I leave client security unconfigured (no username or password), it works. If I enable client security, I can authenticate, browse files or playlists, but as soon as I try to play something, the media player cannot make a connection. Even if I save the playlist to the phone and try opening it directly, the same connection problem occurs.

Could the server be asking for authentication (again) from the media player?

I also tried Firefox mobile for the N900, but it crashes when attempting to start a playlist.

Thanks

SLionB
Posts: 2
Joined: Sun Feb 07, 2010 11:49 am
AV Hardware: WD My World Book Edition 1TB

Re: Enableweb streaming how-to

Postby SLionB » Sun Feb 07, 2010 12:09 pm

I have WD My World Book Edition 1TB NAS (firmware 01.01.16) with Twonky Media Server 5.1 factory installed.
NAS is configured to use static IP address from WD configuration menu.
Although there is remote web access on port 9000 configuring Virtual Server settings on my router, I have exactly the same problem as all the others here.
The links to the media folders and media files have the configured internal static IP and not the WAN IP as it should be.
So I have to change from local IP to wan ip ( or wan dns name ) in my web browser's address bar to access my media.
Notice that there is no option on Twonky Media Server 5.1 to enable web access as mentioned by a member, as there is no Advanced->Network Configuration option!
This problem is in fact rediculus as all we have an ethernet NAS and cannot access it from WEB although this was one of the purposes that we bought it.And we can not use it , not because it is not supported but because of an unacceptable programmatical error !!!!
Shame on you twonky media server developers that you don't give the people an answer to this problem and all our questions remain unanswered for months now!
Last edited by SLionB on Mon Feb 08, 2010 4:15 pm, edited 1 time in total.

Crashdot
Posts: 4
Joined: Wed Jan 27, 2010 5:32 am
AV Hardware: Twonky Media Server 4.4.5 on Windows
Denon AVR-4306
Nokia N900

Re: Enableweb streaming how-to

Postby Crashdot » Sun Feb 07, 2010 1:48 pm

In my case there is an Advanced Setup>Network menu option, that contains all of the settings needed, although I am running 4.4.5. Even if this is not available, it should be possible to make the necessary changes to the ini file directly.

Previously I made the mistake of using the wrong port number in those settings, but now that I am using HTTP remote port 9100 with a dynamic dns account and the appropriate url entered, things do work as intended. The only problem I have is with my remote media player that does not support authentication, but that isn't Twonky related.

I also had mistakedly forwarded the wrong port through my firewall (aka virtual server), which needed to be 9100, not 9000. If your virtual server is set to use 9000, I'm not sure that will work since 9000 is used for LAN and 9100 for WAN. I think that Twonky will continue to return the LAN IP address in your entries as long as you are using port 9000, or at least that is what I recall until I fixed this - and this sounds like what you are experiencing. Please verify you are set to use 9100 and forwarding 9100.

Hope you get it sorted.

Cheers

SLionB
Posts: 2
Joined: Sun Feb 07, 2010 11:49 am
AV Hardware: WD My World Book Edition 1TB

Re: Enableweb streaming how-to

Postby SLionB » Mon Feb 08, 2010 4:13 pm

Crashdot wrote:In my case there is an Advanced Setup>Network menu option, that contains all of the settings needed, although I am running 4.4.5. Even if this is not available, it should be possible to make the necessary changes to the ini file directly.

Previously I made the mistake of using the wrong port number in those settings, but now that I am using HTTP remote port 9100 with a dynamic dns account and the appropriate url entered, things do work as intended. The only problem I have is with my remote media player that does not support authentication, but that isn't Twonky related.

I also had mistakedly forwarded the wrong port through my firewall (aka virtual server), which needed to be 9100, not 9000. If your virtual server is set to use 9000, I'm not sure that will work since 9000 is used for LAN and 9100 for WAN. I think that Twonky will continue to return the LAN IP address in your entries as long as you are using port 9000, or at least that is what I recall until I fixed this - and this sounds like what you are experiencing. Please verify you are set to use 9100 and forwarding 9100.

Hope you get it sorted.

Cheers


Thank you for your reply!
What you say is that Twonky Media Server uses by default differents ports for accessing it either from LAN(port 9000) or WAN (port 9100) !
So if I redirect port 9100 instead of 9000 on my router's configuration this will work magically through WAN using just port 9100!!!!
I don't understand it from technical scope but because it worked in your case I will give it a try!
And if it is working let me give you my best thoughts and wishes because there is nowhere documentated, and noone officially answered to this simple problem.
Others say that they put a simple slash "\" on dyns setting on twonkyvision-media.ini to make this working but we are not all linux experts and why we have to make something complicated for such a simple function is something I don't understand..
So I will try crashdot's method which looks logic and I will inform you , along with the commynity about if it does the job....

Mike118s
Posts: 4
Joined: Sun Jun 13, 2010 3:22 am
AV Hardware: PC

Re: Enableweb streaming how-to

Postby Mike118s » Sun Jun 13, 2010 3:55 am

What a bunch of crap, I knew I should have waited to buy this damn thing as there is always SOMETHING that doesn't work.

THERE IS NO c:\windows\system32\config\systemprofile\roaming\twonkymedia directory or INI on my server

HOW STUPID ARE YOU, Why isn't this setting in the NETWORK section so we don't have to do this.

This is media streaming, how could this not work right out of the box, you know damn well we arent just acessing this from our local lan.

Here I sit with this crap, latest version and still get the local IP when trying to get ot the damn files remotely.
Edited the config..

WINDOWS, where are the windows instruciotns to get this done, as the other user mentioned, what is this 9000 local and 9100 remote going to work? Again, Any help here.... I am pissed, I spent hours trying to fix this damn thing.

Mike118s
Posts: 4
Joined: Sun Jun 13, 2010 3:22 am
AV Hardware: PC

Re: Enableweb streaming how-to

Postby Mike118s » Sun Jun 13, 2010 9:38 am

Better yet, WHY would you need a switch, I call the website up with the External IP, you should hold the damn IP in a variable and use that throughout building the weblinks, why would you let a program call you at 67.x.x.x and then turn the links into 192.x.x.x, all links should be 67.x.x.x. Also thank you for posting my internal IP of the media server, security issue, so if some idiot can hack the external IP, they will know what server to hit internally without having to look for it and maybe do something nice like delete all my content. Thanks.

To boot, I just got a CiscoNAS with 4 1TB drives with this Twonky as the UPNP Media server that I sold to a client, it is doing the same damn thing, I guess I will be getting a call soon, they mainly wanted it for to be useed remotely and who is going to look like an idiot? Me! But I am going to call Cisco and get a refund and tell them it was because this software that doesn't work as advertised, so maybe Cisco will call you. Second reason I am pissed.

1 plus, it works in house! I do like it other than this remote issue.

Mike118s
Posts: 4
Joined: Sun Jun 13, 2010 3:22 am
AV Hardware: PC

Re: Enableweb streaming how-to

Postby Mike118s » Sun Jun 13, 2010 9:41 am

>>This problem is in fact rediculus as all we have an ethernet NAS and cannot access it from WEB although this was one of the purposes that we bought it.And we can not use it , not because it is not supported but because of an unacceptable programmatical error !!!!
Shame on you twonky media server developers that you don't give the people an answer to this problem and all our questions remain unanswered for months now!<<

Great! Exactly! and still no fix. Thanks for telling me its V6.0 V6 what? 6.x.x? After the 6 betas?

Mike118s
Posts: 4
Joined: Sun Jun 13, 2010 3:22 am
AV Hardware: PC

Re: Enableweb streaming how-to

Postby Mike118s » Sun Jun 13, 2010 11:09 pm

--
Twonky Windows Version fixed thanks to my damn self, cannot believe not one person posted this, so no thanks to you selfish a$$ users as well that already fixed it and didn't post it back here.
--
WINDOWS MEDIA MANAGER 2.? with SERVER 6.?.?
This is as of today 6/13/2010
I AM USING DNSDYN.ORG on my LinkSys Router:
Forwarding Port 9100 to my Internal IP x.x.x.12
External Link: http://[ExternalIp/FQDN]:9100
--
SO, thank you dumb A$$ developers, tests and managers for wasting my time. Do you think you can manage to post the complete version somewhere in the APP, is that to much programming for you? like 6.x.x NOT this 6.0 BS. Half of you thier probably don't used the program so you wouldn't know or test it.

My Best guess is the program loads the twonkymedia-server-default.ini from C:\Program Files\TwonkyMedia
appdata=C:\Documents and Settings\All Users\Application Data\TwonkyMedia\
BUT THEN it pulls the settings from
C:\Documents and Settings\All Users\Application Data\twonkymedia\twonkymedia-server.ini

Again, the INI file is located at C:\Documents and Settings\All Users\Application Data\twonkymedia,
It has the settings in the file: twonkymedia-server.ini

USE NOTEPAD PLUS, the best editor around, to edit this damn INI. http://notepad-plus-plus.org/

(Here are a few lines):

# dynamic dns prefix for remote access, including http://
dyndns=http://[ExternalIp/FQDN]

# access to web config pages, 0 for denied, 1 for local only, 2 for open
enableweb=2

# follow symbolic links while scanning (Linux only)
followlinks=1

# http server port for remote access
httpremoteport=9100

So this Worked: http://[ExternalIp/FQDN]/config

Off to fix and test, so far its not steaming to the remote but instead its load the WHOLE DAMN FILE then starts playing and some of the options are working.

Vexille
Posts: 2
Joined: Mon Aug 09, 2010 5:13 am
AV Hardware: WIndows Home Server

Re: Enableweb streaming how-to

Postby Vexille » Mon Aug 09, 2010 5:42 am

I'm in the same boat as you - I've tried the "TwonkyBeam" but it doesn't seem to work either..


What was the "FQDN" you had in your instructions?

Bboy486
Posts: 1
Joined: Wed Aug 25, 2010 6:31 am
AV Hardware: HTC evo media servers o play air

Re: Enableweb streaming how-to

Postby Bboy486 » Wed Aug 25, 2010 6:39 am

Can someone help me understand something. So I enabled remote login without any issue. I navigate to my video folder. I click a movie that I know works via local WiFi. I get a cannot.play this file error.
:(
Here is the thing. I tested the same movie via WiFi and it worked perfectly. I then turned off my phones WiFi and logged in via 3g. No issues getting in but when I go to play the file error.

I am trying to understand what exactly would've caused the.same file to play.fine over WiFi but not.over the internet.

Mandibela
Posts: 6
Joined: Mon Dec 14, 2009 3:00 pm
AV Hardware: Ubuntu 9.10, Sony Bravia 40Z5500, MacBook 10.4.11, Nokia N810, N900, Windows XP SP3, Windows Vista Business, Windows 7 conneceted via Apple AirPort Extreme Base Station

Re: Enableweb streaming how-to

Postby Mandibela » Thu Nov 11, 2010 1:05 pm

Bboy486 wrote:I am trying to understand what exactly would've caused the.same file to play.fine over WiFi but not.over the internet.


WiFi = You're using local network access
over the internet = you're not.

Please, read the posts above.

roozbeh
Posts: 1
Joined: Thu Nov 11, 2010 8:59 pm
AV Hardware: Linux Server, iPhone

Re: Enableweb streaming how-to

Postby roozbeh » Thu Nov 11, 2010 9:10 pm

I spent hours on this hoping that I can see my server over the Internet. I can see the server, as many of you know, I can browse the contents but I cannot play any media. My network setting is fine and I tried it with another media server, Playback on my Mac laptop, and I can see it over the Internet and it works well. So, I contacted Twonky and here is what they replied:

>> In the current TwonkyServer versions you can access Twonky on any other system
>> connected on the same network. The remote access over the internet is not available
>> right now. Hopefully this feature would be available in our future releases.
>>
>> Thanks,
>> The Twonky Team

I think I have wasted my time and my money.

tcviper
Posts: 17
Joined: Wed Feb 17, 2010 3:20 pm
AV Hardware: PS3, XBOX360, HP Homeserver, Dell XPS730X, Bravia TV

Re: Enableweb streaming how-to

Postby tcviper » Fri Dec 03, 2010 11:28 am

That is once again indeed very sad.....

PeeBee
Posts: 392
Joined: Sat Jun 13, 2009 12:16 pm
AV Hardware: Buffalo LS Pro; PS3; Samsung LE37B650

Re: Enableweb streaming how-to

Postby PeeBee » Sat Dec 04, 2010 11:32 am

The future version that is mentioned is TwonkyServer 6.1. An Alpha version is available from a link in this post - Windows, Mac and Linux versions available.

Bear in mind that it is a very early test version and not an official release.

PB
Samsung LE37B650T2WXXU; Liteon 5055GDL+ HDD/DVD Recorder; Playstation 3; Iomega Screenplay HD 500GB; Buffalo Linkstation Pro LS-320GL (running Twonky 6.0.30, SqueezeBox Server 7.6 and acting as a Print Server)


Return to “TwonkyServer”

Who is online

Users browsing this forum: No registered users and 2 guests