FLAC playback interrupted ca. every 15 seconds

Everything about the Netgear support, problems, hints...
rudolffischer
Posts: 2
Joined: Wed Jul 08, 2009 11:15 pm
AV Hardware: ReadyNAS NV
Squeezebox
Sonoro Elements W

FLAC playback interrupted ca. every 15 seconds

Postby rudolffischer » Thu Jul 09, 2009 9:16 am

Hi all,
I am new to this forum and glad to have found this excellent resource. I am using Twonkymedia 4.4.11 on ReadyNAS (the Netgear installation package). When I stream FLAC files to my Sonoro Elements W, playback is interrupted and the file is re-buffered around every 15 seconds. This does not happen when I stream with the DLNA server built into ReadyNAS.
I tried increasing the streaming buffer size in Twonkymedia to 128000, but that didn't help. Does anyone have an idea what might be the issue here?
Streaming MP3 files from Twonkymedia to the Sonoro works without any problem.
Thanks and Regards
Rudi

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: FLAC playback interrupted ca. every 15 seconds

Postby Briain » Thu Jul 09, 2009 2:36 pm

Hi

That's an odd one. I can certainly say that streaming FLAC files from a ReadyNAS and Twonky 4.4.11 to Linn DS players works a treat. If they ever have pauses, it's usually due to a network problem more than a server problem, however, there are loads and loads of people I know with TMS4.4.11/ReadyNAS who have never had a single issue with streaming (including myself).

One thing you should try is to disable the built in ReadyDNLA (by unticking the tick box in Frontview) just in case it is somehow conflicting with something that Twonky is doing. I don't know if it'll help, but since it only takes a few seconds and is easily restored by simply ticking the box again, it's certainly worth a try just to remove it from the mix of possibilities.

Sorry but I know nothing about the Sonoro so can't suggest anything to try there. The fact that ReadyDNLA can stream to it would indicate that the problem probably isn't with the Sonoro though; that's why I have suggested the above as the first check.

Bri

User avatar
Briain
Posts: 478
Joined: Thu Jan 03, 2008 8:07 pm
AV Hardware: Linn Klimax DS
Linn Majik DS-I
Linn Sneaky DS
WDTV Live Hib
Sonos 80
Location: Edinburgh, Scotland

Re: FLAC playback interrupted ca. every 15 seconds

Postby Briain » Fri Jul 10, 2009 12:55 am

Actually, another issue I'd forgotten is the rescan time. If this is set incorrectly (really low) the NAS can be almost continuously scanning and thus needlessly using up resources. This could be another reason why data flow is being interrupted and thus why you are getting dropouts. To check this, set the rescan to 0 and see if that helps.

I tended to use TMS4 with the rescan set to 0 and simply rescan manually whenever I uploaded any media. There's no point in it scanning every hour (or day, or even week) of you've not added any new media; it just wastes resources.

Bri

k1200rs
Posts: 340
Joined: Wed Jul 27, 2005 9:24 pm
AV Hardware: Does no longer attend this forum.
Location: Somewhere in the French Alps

Re: FLAC playback interrupted ca. every 15 seconds

Postby k1200rs » Sat Sep 26, 2009 1:01 pm

rudolffischer wrote:Hi all,
I am new to this forum and glad to have found this excellent resource. I am using Twonkymedia 4.4.11 on ReadyNAS (the Netgear installation package). When I stream FLAC files to my Sonoro Elements W, playback is interrupted and the file is re-buffered around every 15 seconds. This does not happen when I stream with the DLNA server built into ReadyNAS.
I tried increasing the streaming buffer size in Twonkymedia to 128000, but that didn't help. Does anyone have an idea what might be the issue here?
Streaming MP3 files from Twonkymedia to the Sonoro works without any problem.
Thanks and Regards
Rudi



The throughput needed by FLAC is 2 to 10 times more than MP3 (depends what MP3 quality your are talking about and what compression rate used by the FLAC ripper).
So, this might be related to your LAN or WIFI.
If you are in WIFI, have you tried connecting your device with a Ethernet cable?

rudolffischer
Posts: 2
Joined: Wed Jul 08, 2009 11:15 pm
AV Hardware: ReadyNAS NV
Squeezebox
Sonoro Elements W

Re: FLAC playback interrupted ca. every 15 seconds

Postby rudolffischer » Sat Jan 30, 2010 2:13 am

Thanks a lot for all the suggestions and apologies for not getting back.
In the meantime I have upgraded to Twonky 5.0.68, hoping that would solve the issue. No improvment though. ReadyDNLA is turned off. I am connecting through ethernet, so wifi is not an issue. My lan installation is quite simple. From the sonoro to a 100mbit/s switch to the ReadyNAS, so there's little room for problems there.
With ReadyDLNA Flac streaming works without a hitch, so I would think the Sonoro, cabling and router can be ruled out as causes.
I guess I'll stick to MP3 for the time being, as I prefer the functionality of Twonky over the ReadyDLNA.


Return to “Netgear”

Who is online

Users browsing this forum: No registered users and 2 guests

cron