Licensing help - Please!

Other OS or NAS discussions
developer
Posts: 3
Joined: Wed May 06, 2015 3:48 pm
AV Hardware: Restuffed Linkstation Live and Pro serving video and music, rooted, telnet, Samsung Smart TVs, canopus, etc.

Licensing help - Please!

Postby developer » Sat Jan 02, 2016 4:49 am

I've been using Twonky for many years, upgrading, etc., and I always used my official license.

Today, using 8.0.3 on a Linkstation Pro, following a reboot, I received: no valid license found <upnp_mediaserver_start>

I tried reinstalls, etc., and now, seeing that 8.2 was available, I upgraded, but still no joy.

Here is the latest message. I won't even run long enough for me to enter my license...

"For image conversion and scaling the TwonkyServer utilizes ImageMagick.
For details on the license please see /mnt/disk1/twonky/cgi-bin/convert-readme.txt
Twonky Version 8.2
Snapshot Twonky_8.2_Release20151008 TA:1fca761c71fc6c0a94f7aa5c282ffaf4dfe3c780
Platform BuffaloLinkstationPro_arm_marvell_le_softfloat
2016-01-01 22:39:04:359 [Critical] - LOG_SYSTEM: 120: no valid license found (upnp_mediaserver_start)

Does anyone have any idea what I have to do to get this to operate at least long enough to get my license entered?

Thanks in advance!

developer
Posts: 3
Joined: Wed May 06, 2015 3:48 pm
AV Hardware: Restuffed Linkstation Live and Pro serving video and music, rooted, telnet, Samsung Smart TVs, canopus, etc.

Re: Licensing help - Please! - SOLVED!

Postby developer » Sat Jan 02, 2016 7:42 pm

Just an update. I solved this with the help of support, but I still have no idea how this got to be how it was...

The problem was that my original appdata directory was always /var/twonky/TwonkyServer For some reason, this changed to /var/twonky/twonkyserver and that must have been corrupted. I found the one that was created Jan 1, 2016, deleted that directory and then restarted twonky manually from the commandline as root. This time it started. I brought up the admin gui on port 9000 and it asked for my license key. I entered it and all is good once again. I hope this helps someone.


Return to “NAS and other OS”

Who is online

Users browsing this forum: No registered users and 2 guests

cron